Monday, July 6, 2009

1.01 released, FAQ and reviews

1.01 has been released in the app store. This is a bug fix update that fixes sticky/slowdown issues experienced by some users in the first version.

I am working on making a FAQ page on this blog so that people can see quick answers to recurring problems. I am also working resolving SSL and authentication problems people are having for the next release. Keep an eye out on this page for updates on that.

Finally, there are a ton of 1 star reviews on itunes, some from people looking for the settings menu. I've decided to ditch the standard apple menu and make my own in application to reduce confusion. In the mean time, if you have used the application and find it useful, please consider giving a positive star rating in itunes. You do not have to write anything, just give it a star rating. There are 50 people who gave 1 star reviews and close to a thousand users, it would be unfortunate for the 50 to drown out the rest. Thanks!

15 comments:

  1. Trust me.. this app seems like something big.. As soon as I can connect to my company's IM server (we're using Spark), I'd rate you 5 stars everywhere.
    Thanks for all the hard work you put into this, I'll make sure to have everyone I know download it and rate it for the 5 star app this can be ;)
    Also let me know if you can give me something I can test with my company's IM server to see if I can get it to connect. Thanks!

    ReplyDelete
  2. Well.. I got further!! Port 5222, resource Spark and SSL off, gives me a list of buddies... but then the app hangs, I can't do anything in it...

    ReplyDelete
  3. Please don't listen to dumb people and leave the settings menu where it is now !!! Idiots can go kill themselves.

    ReplyDelete
  4. Nick, i am shifting focus to getting spark/openfire connections to work better with different settings. Hopefully 1.02 will have all those bugs ironed out.

    ReplyDelete
  5. Anu,

    Would like to talk to you about a business opportunity for your app. How can I contact you?

    ReplyDelete
  6. This comment has been removed by the author.

    ReplyDelete
  7. I cannot connect to my server with my iPhone using 3.0. What resource setting should I be using if I want to connect to an xmpp/Spark work server? I cannot figure out what I am doing wrong ...

    ReplyDelete
  8. To Mario:
    Anu is working on Spark and should get it fixed in the next release (1.02). Anu how's it going so far? Thanks for everything btw!

    ReplyDelete
  9. Hi there, I seem to be having issues with using it with ejabberd. I've turned off encryption on the server, but that doesn't seem to make a difference. It seems to disconnect almost immediately.

    iphone3gs - os3.0
    ejabberd - 2.0.3-1

    packet traces don't yield any clues, logging doesn't appear to indicate anything obvious either. any tips?

    ReplyDelete
  10. Hello there, could you give inside you FAQ a basic how-to for configuration? I am stuck at the config part and can't get connected (jabber.cz).

    ReplyDelete
  11. Does this actually require 3.0? As I'm now stuck with the old laggy 1.0 version of SworIM, which is totally unusable.

    ReplyDelete
  12. Doesn't work for me using a private jabberd server, with an stunnel-based SSL layer and a cacert-based server certificate. Here are the logs from the server:

    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078652416]: jabber accepted FD=11 from 24.114.234.33:15611
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: jabber started
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: FD 11 in non-blocking mode
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: FD 12 in non-blocking mode
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: FD 13 in non-blocking mode
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: Connection from 24.114.234.33:15611 permitted by libwrap
    Jul 19 17:58:48 hostx stunnel: LOG5[32493:1078909840]: jabber connected from 24.114.234.33:15611
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: SSL state (accept): before/accept initialization
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078652416]: Cleaning up the signal pipe
    Jul 19 17:58:48 hostx stunnel: LOG6[32493:1078652416]: Child process 32504 finished with code 0
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: SSL state (accept): SSLv3 read client hello A
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: SSL state (accept): SSLv3 write server hello A
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: SSL state (accept): SSLv3 write certificate A
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: SSL state (accept): SSLv3 write server done A
    Jul 19 17:58:48 hostx stunnel: LOG7[32493:1078909840]: SSL state (accept): SSLv3 flush data
    Jul 19 17:58:54 hostx stunnel: LOG3[32493:1078909840]: SSL_accept: Peer suddenly disconnected
    Jul 19 17:58:54 hostx stunnel: LOG5[32493:1078909840]: Connection reset: 0 bytes sent to SSL, 0 bytes sent to socket
    Jul 19 17:58:54 hostx stunnel: LOG7[32493:1078909840]: jabber finished (2 left)

    ReplyDelete
  13. i am testing with openfire right now with a variety of configurations. Things a little slower right now. Real life tends to take top priority.

    ReplyDelete
  14. This comment has been removed by the author.

    ReplyDelete

Note: Only a member of this blog may post a comment.